PHP 7.1 går i graven – dags att uppgradera

PHP-kod

Den 1 december 2019 når PHP 7.1 End of Life vilket innebär att denna version kommer att sluta underhållas och säkerhetsuppdateras av dess utvecklare. Det betyder att du som använder PHP 7.1 idag behöver uppgradera till en senare PHP-version så snart som möjligt för att din hemsida ska fortsätta fungera, bli snabbare och hållas säker även nästa år.

» Guide: Så väljer du en senare PHP-version i Loopia Kundzon

Ska du uppdatera från PHP 7.1 till 7.2? Se över din kod nu

Utvecklarna av PHP har ansträngt sig för att göra uppgraderingen mellan olika versioner så smidig som möjlig. Trots detta rekommenderar vi att du ser över din hemsidas programkod för att försäkra dig om att den fungerar som tidigare. Gör så här:

  • Uppdatera till den senaste versionen av WordPress/Joomla/OpenCart, beroende på vilket verktyg du använder. Aktuell version och information om hur du uppdaterar hittar du på respektive leverantörs hemsida.
  • Uppdatera alla tillägg och teman till den senaste versionen och se till så att de är kompatibla med PHP 7.2, det sker inte alltid per automatik. Om dina tillägg har uppdaterats under senaste året bör de dock vara redo för PHP 7.2+ men det skadar inte att dubbelkolla med utvecklarna av ditt tema/tillägg.
  • Läs igenom guiderna nedan och stäm av så att du har förberett din hemsida inför uppgraderingen till 7.2. Notera att om du programmerat din sida själv med mysql_*-funktioner behöver du byta dem till mysqli eller PDO. Har du en senare version av WordPress/Joomla/OpenCart använder du redan korrekta databasanslutningar.

    » Uppgradering från 7.1 till 7.2
    » Uppgradering från 7.2 till 7.3

Vad är PHP?

PHP står för Hypertext Preprocessor och är ett skriptspråk som främst körs på webbservrar för att driva sajter med dynamiskt innehåll (t ex bloggar, nyhetsflöden, sökmotorer, etc). Vi på Loopia erbjuder PHP på samtliga av våra UNIX-servrar.

Dela detta inlägg:

Lämna ett svar

E-postadressen publiceras inte. Obligatoriska fält är märkta *