WordPress 5.7 kommer snart och med den versionen kommer en stor förändring

WordPress står för 30 procent av alla webbsajter

WordPress 5.7 är beräknat att släppas den 9 mars och blir då den första stora releasen av WordPress under 2021. En stor förändring är att det tas ett stort jQuery-kliv från version 1.12.4 till 3.5.1.

Vad är jQuery?

jQuery är ett javascript-bibliotek. Många av de funktioner som finns i WordPress och dess teman/tillägg är beroende av jQuery och det är därför en viktig del av hemsidor som är byggda med WordPress.

Varför genomförs denna uppdatering från utvecklarna av WordPress?

Den nuvarande versionen av jQuery som används av utvecklarna är sedan länge ansedd som utdaterad och osäker. Denna uppdatering kommer utöver den ökade säkerheten också göra din WordPress-installation mer effektiv nu när gammal kod byts ut mot ny och modern. Arbetet med att byta ut jQuery påbörjades redan med WordPress 5.5 och i och med version 5.7 slutförs arbetet. 

Påverkar uppdateringen just min hemsida och kan jag göra något för att förbereda mig?

I och med att man redan i WordPress 5.5 påbörjade arbetet borde du redan ha upptäckt om exempelvis menyer, tillägg etc inte har fungerat på din hemsida. Fungerar allt som det ska idag och du har den senaste versionen av WordPress (5.6.1 i skrivande stund) kommer du troligen inte att märka av denna uppdatering. 

Om du i dagsläget har en WordPress-version före 5.5 men planerar att uppdatera till senaste versionen av WordPress (alltid rekommenderat) kan det vara bra att du redan nu kikar igenom din hemsida. Detta gör du genom att installera tillägget Enable jQuery Migrate Helper på din WordPress-sida. Tillägget kan redan nu kika igenom din sida och varna dig om den innehåller något som just nu är beroende av den äldre jQuery-versionen.

Om du redan har uppdaterat till 5.5 och upplever att din sida uppför sig märkligt kan du i detta tillägg också välja att ställa in så att sidan körs på den gamla versionen av jQuery. Detta är dock enbart rekommenderat som en nödlösning medan du lagar/byter ut de delar av sidan som är beroende av den äldre jQuery-versionen.

Utvecklarna av jQuery Migrate Helper har flaggat för att de troligen inte ser någon vidareutveckling av tillägget utan att du framöver istället bör se till att de teman och tillägg du använder är uppdaterade för den nyare jQuery-versionen som WordPress använder från och med version 5.7.

Kan Loopias support hjälpa mig med detta?

Att felsöka och uppdatera din WordPress-sida bör i första hand utföras av dig som har installerat och administrerar sidan. Om ett tema eller tillägg inte fungerar korrekt i senare versioner av WordPress bör supporten för respektive tema/tillägg kontaktas i första hand.

Loopias support kan hjälpa till med att felsöka varför din hemsida inte fungerar eller installera tillägget, men om din hemsida kräver ett större arbete för att anpassas till senare versioner av WordPress och du själv känner att du inte har kunskapen rekommenderar vi att du anlitar en WordPress-utvecklare/webbyrå. 

Hör gärna av dig till vår återförsäljaravdelning på af@loopia.se så kan vi förmedla kontakt med en duktig WordPress-utvecklare från vårt nätverk av nära 4 000 webbyråer.

Dela detta inlägg:

Lämna ett svar

Din e-postadress kommer inte publiceras. Obligatoriska fält är märkta *