Shellshock, är din VPS uppdaterad?

Igår upptäcktes en väldigt allvarlig bugg i programmet ”Bash” som är vanligt på många servrar och Unix-baserade datorer.

”Bash” är ett så kallat ”shell” och används för att skicka kommandon till datorn via en text-terminal, på samma sätt som ”cmd” används i Windows. Just Bash är utan tvivel det allra vanligaste shell-programmet och används som standard i de flesta Linux- och Mac-versioner, vilket är en av anledningarna till att denna bugg är så allvarlig.

Buggen fick namnet Shellshock.

För mindre än ett halvår sedan upptäcktes buggen Heartbleed i mjukvaran OpenSSL som många ansåg vara den allvarligaste buggen någonsin. Nu säger experter att Shellshock är lika allvarlig.

När Shellshock upptäcktes igår spreds informationen snabbt globalt och våra tekniker undersökte omedelbart våra servrar för att se om de var sårbara på grund av denna bugg, men vi kom fram till att vi varken är eller har varit i farozonen, så du som är webbhotellskund till oss kan andas ut.

Om du har en LoopiaVPS hos oss eller en server på annan plats bör du uppdatera Bash snarast.

För att testa om din version av Bash är sårbar kan du köra följande kommando:

rm -f echo; env -i  X='() { (a)=>\' bash -c 'echo date'; cat echo

Om det kommandot visar datum och tidpunkt behöver du uppdatera Bash.

I Ubuntu och andra Debian-baserade Linux-distributioner uppdaterar du Bash med nedanstående kommandorad:

sudo apt-get update && sudo apt-get install --only-upgrade bash

I CentOS och andra RHEL-baserade system uppdaterar du med nedanstående kommando:

yum -y update bash

Om du uppdaterade igår rekommenderas du att uppdatera igen, då nya patchar släpptes under morgonen för de flesta system.

För dig som vill ha mer information om Shellshock rekommenderar vi nedanstående länk:
Everything you need to know about the Shellshock Bash bug

//Stefan P, VPS-ansvarig

Dela: Facebooktwittergoogle_pluslinkedinmail

Kommentera

E-postadressen publiceras inte. Obligatoriska fält är märkta *