PHP 5.3.2 är här, kolla din kod nu!

För några veckor sedan förvarnade vi om att vi kommer att uppdatera PHP 5.2 till 5.3 på våra FreeBSD-serverar. Nu har PHP 5.3.2 kommit, och det innebär att vid nästa uppdatering av FreeBSD kommer vi  överge PHP 5.2 till förmån för det modernare 5.3.

Som vi skrev så innebär den nya versionen ganska stora förändringar, vilket gör att det är otroligt viktigt att ni kontrollerar att er kod kommer att fungera även efter uppdateringen.

Nedan hittar du mer information och hjälp kring hur du ska gå tillväga för att övergången från 5.2 till 5.3 ska gå smidigt.

Du som kör tredjepartsprogram som t ex WordPress eller Joomla måste också se över att du har en version som är kompatibel med 5.3. Detta gör du på respektive tillverkares hemsida.

Tyvärr kan vi inte ännu ge något exakt datum för när detta kommer att ske. Men vänta inte längre. Sätt igång att kontrollera din kod nu direkt, då blir den här uppdateringen en smidig övergång till en modernare och bättre kodbas för din sajt.

Dela: Facebooktwittergoogle_pluslinkedinmail

14 reaktion på “PHP 5.3.2 är här, kolla din kod nu!

  1. Tård Wennerborg Inläggsförfattare

    Hej Fredrik,

    Jag kan tyvärr inte vara mer specifik än att det kommer att ske ”ganska snart”. Vi kan dra ut på det tills det dyker upp någon viktig säkerhetspatch till FreeBSD, men när det scenariot uppstår kan vi inte längre vänta för att undvika ett osäkert system.

    Därför är det viktigt att se över sin kod så snart som möjligt.

  2. Emil Eriksson

    Är det här en uppgradering som genomförts eller är det något som fortfarande kommer ske ”ganska snart”? Enligt phpinfo() är det fortfarande php 5.2.14.

    Det jag framförallt saknar är str_getcsv() och lambda-funktioner.

  3. Tård Wennerborg Inläggsförfattare

    Hej Emil,

    Det är inte genomfört ännu. För att i största möjliga mån undvika komplikationer för de kunder som kör kod som inte är kompatibel med 5.3 gör vi grundliga tester. Vi kommer att gå ut med mer information inom kort för när och hur övergången kommer att gå till.

  4. Robban

    Hej,

    Har väntat länge nu på att PHP 5.3 skall uppgraderas..
    PHP 5.2 är en säkerhetsrisk!! Se till att få fart på arbetet och sätt igång och uppgradera!

    Själv har jag tröttnat på att vänta och köpt mig ett webbhotell hos annan leverantör tills ni fått tummarna ur…

  5. Johan

    Hmm, fortfarande ingen uppgradering till PHP 5.3?

    ”Inom kort” är alltså relativt?

  6. Ingvar Loco Nordin

    Jag vet INGET om kodning, är noll utbildad i detta; publicerar ganska mycket text och bilder med Dreamweaver CS4 – och jag fattar absolut inget av vad man talar om. Hur ska JAG förstå OM jag måste göra något, och VAD?

  7. Tård Wennerborg Inläggsförfattare

    Det låter som du publicerar statiska texter och bilder via Dreamweaver, därför behöver du troligtvis behöver du inte göra något. Men kontakta vår support med kundnummer och detaljer så hjälper vi dig om du fortfarande känner dig osäker.

  8. Johan

    Ok, vi har FORTFARANDE (över ett år efter att detta inlägg gjordes) PHP 5.2.5. Vad hände med
    ”Vi uppdaterar alla servrar löpande sedan en vecka tillbaka. Så snart är det din tur också ”

    ????

Kommentera

E-postadressen publiceras inte. Obligatoriska fält är märkta *