Nu är det dags för PHP 5.3 och Apache 2.2

Nu är det dags! På tisdag 23/11 börjar vi uppdatera våra webbservrar med PHP 5.3.3 och Apache 2.2. Som vi varnat för tidigare kan uppdateringarna påverka din sajt om den innehåller omodern kod.

Så här kan PHP 5.3 påverka din sajt

Den nya versionen av PHP innebär ganska stora förändringar, vilket gör att det är otroligt viktigt att du kollar att din kod är kompatibel innan övergången.

Kör du ett tredjepartsprogram som WordPress eller Joomla bör du se till att du har den senaste versionen. Har du knackat ihop din sida själv så kan du ta hjälp av nedanstående länkar för att få koll på vad som eventuellt behöver göras:

Så här kan Apache 2.2 påverka din sajt

Beteendet för RewriteRule har ändrats, så du som har använt dig av det behöver se över detta enligt vår guide här.

Har du funderingar kring något av ovanstående så tveka inte att kontakta vår support så hjälper vi dig.

22 reaktion på “Nu är det dags för PHP 5.3 och Apache 2.2

  1. Besserwisser

    Beteendet på RewriteBase? Det stod det inte i er artikel, utan där berörde ni det ändrade beteendet i RewriteRule.

  2. Martin Sköld

    Vad händer med alla dem som ligger med en drupal sidor hos er. Har ni lagt en tanke på att alla drupal siter kommer sluta fungera…

    /M

  3. Tård Wennerborg Inläggsförfattare

    Hej Martin,
    Drupal har stöd för PHP 5.3 från version 6.14 (aktuell version är 6.19). Ett perfekt läge att kontrollera att du kör den senaste versionen av Drupal ;-).

  4. Martin Sköld

    Jo de vet jag men ”tyvärr” byggs drupal siter upp av moduler för olika funktioner och många av dessa stödjer tyvärr inte 5.3.
    Varför kan man inte få välja vilken version man vill köra. Finns faktiskt som val på många andra webbhotell.

    Kör ca 15 siter/konton hos er med drupal och om de uppdateras så måste jag tyvärr meddela att jag måste flytta dem eftersom jag redan har testat med php 5.3 på dem modulerna som är installerade. Vilket jag verkligen inte vill göra eftersom jag anser loopia vara väldigt stabila och goa att ha med att göra.

    /M

  5. Tård Wennerborg Inläggsförfattare

    Hej igen Martin.
    Vi kommer att behålla en server med 5.2 ett litet tag för de som behöver lite extra tid att förbereda sig för migreringen. Hör av dig till support@loopia.se med kundnummer och detaljer så ser vi till att du placeras på den servern. Det är dock ingen permanent lösning, utan bara ett sätt att hjälpa de som behöver mer tid för att göra migreringen på ett bra sätt.

  6. Martin Sköld

    varför ger ni inte era kunder valmöjligheten till de? Eftersom andra webbhotell erbjuder så borde ni också kunna bygga in de i er kontrollpanel. Borde bara handla om vilken php.ini som ska laddas…

    /M

  7. Tård Wennerborg Inläggsförfattare

    I takt med att utvecklingen går framåt måste vi även se till att våra system följer den. Se det som ett perfekt tillfälle att uppdatera de system du använder till modern kod ;-). Vi förstår att detta kan innebära mycket justeringar för de som sitter på äldre system. Därför började vi redan i början av mars gå ut med information om vilka uppdateringar som var på gång, och därför erbjuder vi de som behöver lite extra tid genom att behålla en server. Men vi kan inte permanent behålla föråldrade system.

  8. Martin Sköld

    De är bra men fortfarande är de väl ändå kunder till er som kommer drabbas väldigt hårt.
    Jag säger bara att ni borde kanske kunna diskutera möjligheten om att kunna ha valbar php version. I alla fall något år framåt. Speciellt när de kan innebära stora förändringar för era kunder.

    Jag säger absolute inte att de är fel att gå framåt men även ni måste kunna vara bakåt kompatibla som alla andra programvaror.

  9. Tård Wennerborg Inläggsförfattare

    Vi förstår din önskan och de bestyr det innebär för dig. Just därför har vi under 9 månader gått ut med information om uppdateringen, vad det innebär för förändringar och var man hittar information om hur man migrerar till kod som är anpassad för PHP 5.3. Precis som med Drupal så finns det äldre versioner av WordPress, Joomla och andra tredjepartsprodukter som inte fungerar med PHP 5.3. Därför har vi också varit noga med att påpeka hur viktigt det är att uppdatera dessa (förutom modernare kodbas är det viktigt ur säkerhetssynkpunkt att köra den senaste versionen oavsett vilken produkt man använder).

    Vi behöver helt enkelt sätta en tidsgräns för att möjliggöra den här uppdateringen. Vi arbetar hårt för att migreringen ska gå så smidigt som möjligt för alla kunder som berörs. Därför ger vi som sagt de kunder som behöver ytterligare tid möjligheten att under en kortare period ligga på en server som kör 5.2. Kontakta support@loopia.se med kundnummer och detaljer så ser vi till att du placeras där.

  10. Carl Gren

    Då är väl sqLite 3 aktiverat som standard enligt:
    php.net/manual/en/sqlite3.installation.php

    Vi behöver både sqLite 2 och sqLite 3 till vårt webbhotell.

    MVH: Carl Gren

  11. Pontus Berglund

    Härligt, då kraschade i stort sett alla mina WP-siter nu trots att själva stommen är av senaste version. Det är något plugin som inte hanterar 5.3 troligtvis, blir till att sitta och felsöka hela natten.

    Frågan är hur man löser det om/när ett kritiskt plugin helt enkelt inte stöder 5.3. Ser ingen annan lösning än att byta hotell till något där man kan välja version..

  12. Tård Wennerborg Inläggsförfattare

    Hej Pontus,

    Tråkigt att höra att du råkat på patrull vid uppdateringen. Vi har under 9 månader förvarnat om den här uppdateringen och vad den innebär för förändringar, och på så sätt försökt göra det möjligt för alla att kontrollera sin kod. Men vi vill vi självklart att det ska gå så smidigt som möjligt för alla att migrera till den nya plattformen.

    Som jag skriver ovan så kommer vi att under en kortare period att behålla en server som kör 5.2. Kontakta vår support så hjälper de dig att flytta de sajter du behöver se över innan migreringen. Då får du möjlighet att kontrollera vilket plugin som ställer till det, utan att dina sidor är ”trasiga” under tiden.

  13. Claes

    Helt oacceptabelt Loopia!

    I och med detta gör ni det svårt att fortsätta jobba med er.

    Det handlar inte om hur lång tid man har på sig att ändra sin kod. Det handlar om att det är ett arbete, alltså en kostnad, som måste utföras. Vissa sidor och system måste till och med skrivas om helt från grunden!

    Trodde ni arbetade för att underlätta för era kunder och inte tvärtom. Låt kunden bestämma vilken plattform och version som ska köras.

  14. Johan

    Jag är glad att jag inte är kund till dig Claes. Det du säger är att Loopia skapat ett merarbete för dig som utvecklat saker på en gammal teknisk plattform med diverse säkerhetshål som du inte tänker bry dig om.

    Loopia gör ju detta för att förbättra för dig som kund men kräver i gengäld att du som kund bjuder tillbaka och ser till att ha någolunda uppdaterad kod.
    Loopia vill väl inte ha kvar gamla PHP-versioner som orsakar diverse fel på servrarna utan har valt att nästan 2 år efter att 5.3 kom äntligen uppgradera detta. Bra gjort Loopia.

    Åker du fortfarande runt med en flaska blyersättning i bilen också?

  15. Tård Wennerborg Inläggsförfattare

    Hej Claes,

    Vi gör allt vad vi kan för att underlätta migreringen för er kunder. Därför började vi informera nio månader i förväg om uppdateringen och var tydliga med vad det skulle komma att innebära för förändringar, vilka delar i koden du bör se över etc.

    På ett webbhotell så delar du som kund plattform och miljö med alla andra kunder på samma server, det innebär att alla är tvungna att följa samma utveckling samtidigt.

    Det är viktigt att hänga med i utvecklingen av många skäl, dels är det en stor mängd kunder som efterfrågar de nya funktioner som de nya versionerna innebär. Men det är också viktigt för säkerheten. På äldre system som inte längre uppdateras av tillverkaren blir säkerhetshål och buggar som upptäcks aldrig tilltäppta t ex. I juli i år kom den sista uppdateringen av PHP 5.2 (5.2.14 för att vara exakt), i samband med detta gick PHP-gruppen också ut med följande meddelande ”This release marks the end of the active support for PHP 5.2. Following this release the PHP 5.2 series will receive no further active bug maintenance. Security fixes for PHP 5.2 might be published on a case by cases basis. All users of PHP 5.2 are encouraged to upgrade to PHP 5.3.” (Läs mer på http://www.php.net/archive/2010.php#id2010-07-22-1)

    För att underlätta ytterligare sparar vi som sagt en server med 5.2 under en kortare övergångsperiod. Kontakta support@loopia.se med kundnummer och detaljer så flyttar vi ditt konto till den servern om du behöver lite mer tid att se över din kod.

  16. Claes

    @Johan: Jag förstår din tanke. Men håller inte med.

    Om jag nu åker bil med blyersättning så har jag fortfarande möjlighet att fortsätta göra det eftersom att det erbjuds blyersättning.

    Vad som är kritiskt för min sajt ska inte Loopia bestämma. Dom ska självklart göra det möjligt för mig, genom server uppdateringar, att använda den senaste och säkraste tekniken. Men det ska INTE vara obligatoriskt.

    Ingen av de sajter vi har utvecklat har haft några problem mer än att kommentarer har inletts med #.

    Men jag vet, och du kan se det själv i föregående poster till detta blogginlägg, att många har stora problem. För dig spelar det ingen roll att vissa saker slutar fungera eftersom att det inte påverkar dig. Men tänk ett steg längre och på dom det påverkar.

    Det är nog inte kul att vara en liten enmansfirma och omsätta några hundra tusen på sin webbshop som man har som en extra inkomstkälla om den slutar fungera p.g.a. en uppdatering på webbhotellet.
    Hur ska enmansfirman lösa problemet? Finns det ekonomi för enmansfirman att lösa problemet?

    För ett större företag som bedriver e-handel är detta inget problem.

  17. Emil

    Bra att ni står på er Loopia. Att hänga med i de nya PHP-versionerna är jobbigt, men något man bör vänja sig vid om man väljer den plattformen.

    Det här kommer även gäller i framtiden (PHP 5.4 el. 6.0) osv. Lika bra att vänja sig och bara köra de plugins man underhålls.

    Det finns redan för mycket stöd för t.ex. PHP4 och exempel på dålig PHP4-kod.

    Kan man / inte har råd att hantera sin teknikplattform kanske man ska tänka om. Det finns många andra lösningar som inte kräver att man är PHP-expert.

  18. Dennis Modig

    Då var det hejdå till alla kunder med oscommerce. För där finns inget stöd för PHP 5.3 ännu.

Kommentera

E-postadressen publiceras inte. Obligatoriska fält är märkta *

Följande HTML-taggar och attribut är tillåtna: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>